Outage on Vivantio for a small number of customers
Incident Report for Vivantio
Postmortem

Duration

25th May 2023
Initial customer ticket raised 10:42 (UTC)
Incident status notification raised 10:55 (UTC)
Fix released and incident moved to monitoring stage 15:10 (UTC)
Incident status page marked as fully resolved 16:11 (UTC)

 

Impact: A small number of customers noted an intermittent issue logging into Vivantio. Some of the customers who raised tickets to us, found that once they were in the system, they could maintain access whilst a few experienced issues logging in throughout the incident period.

 

Cause: After investigation by the Vivantio engineering team, the cause of the issue was determined to be due to a database change being made in preparation for an upcoming release. This database change conflicted with a configuration of the Vivantio Classic UI on one of our web servers, the Vivantio FLEX UI was unaffected but there is a dependency between the login page of the two user interfaces which caused some FLEX UI users being unable to login. 

 

Resolution: Our engineers performed an extensive investigation into the issue and once the root cause was established, they rolled back the database change which corrected the issue. The Vivantio QA team tested the system fully before we updated the incident status page and continued to monitor the system for a subsequent period of time.

 

The Engineers will continue to evaluate the cause and will take all findings into consideration for future enhancements and releases and improvements to our QA procedures. All of our platforms are being fully reviewed for configuration issues across both the Classic and FLEX user interfaces to ensure this does not happen again in the future.

Posted May 26, 2023 - 10:57 UTC

Resolved
Following onto the resolution of the issue that impacted some of our customers today, our Engineers have been monitoring the situation since the fix was applied. No further issues have become apparent.

We will now mark this incident as resolved, however should any customer experience continued issues please do let the Vivantio support team know so we can investigate.

As detailed earlier, a post mortem will be added to this incident page within 2 working days.

We would like to thank you once more for your extended patience with this issue today.
Posted May 25, 2023 - 16:11 UTC
Monitoring
A fix has been found and implemented and we are hopeful that all customers should be able to use Vivantio as expected.

We appreciate this intermittent issue has impacted some customers for a few hours and we are sure it has been frustrating for some. We are most grateful for your patience throughout. If any customer is still experiencing issues with using their system please let the Vivantio support team know so they can investigate it on your behalf.

We will be working with our engineering team to get a full understanding of the root cause and a post mortem will be applied to this status page within two working days.

Our team will continue to monitor the system.
Posted May 25, 2023 - 15:10 UTC
Update
We are continuing to investigate the issue which is preventing some users from logging into their Vivantio System. We are aware that some users have managed to access the system; who could not do so earlier; and they have managed to work in Flex successfully, but they still have issues via Classic.

We are aware however, that this intermittent issue is resulting in some users not getting access via the log in page at all.

All of the Vivantio engineers are working on this issue and it remains their top priority. We will update this status page in due course.

Once more, we thank you for your patience in this matter.
Posted May 25, 2023 - 14:50 UTC
Update
Our Engineers are continuing to work on the issue that is preventing some users from logging into their Vivantio system. The team are currently trying a fix. Our team hope to have this fix completed within 60-90 minutes. We will update this page once we have insight of the progression.

We apologise profusely for the disruption to your working activities and appreciate your continued patience throughout.

Thank you
Posted May 25, 2023 - 13:12 UTC
Update
We are continuing to investigate the issue as a priority and apologise to all customers who are being impacted.

As soon as we have a further update from the engineering team we will update this status page.

Thank you for your continued patience.
Posted May 25, 2023 - 12:14 UTC
Update
Our engineers are continuing to investigate the issue which appears to be impacting some of our customers. We will update this page further within 45 minutes or sooner if we have more information.

We would like to thank those customers, who are being affected by this , for their patience.
Posted May 25, 2023 - 11:26 UTC
Investigating
We are currently experiencing an issue where a number of customers are unable to login to Vivantio.
This issue is being investigated and we will update you shortly.

Please accept our sincere apologies for the inconvenience caused and we would like to thank you for your patience, whilst this is resolved.
Posted May 25, 2023 - 10:55 UTC
This incident affected: Vivantio Platform (Main Vivantio Application).