Performance issues impacting some customers

Incident Report for Vivantio

Postmortem

Incident Post-Mortem Summary

Date: Monday 13th July 2026

Timeline

  • 19:00 UTC: Initial customer ticket received. Treated as an isolated incident.
  • 19:50 UTC: Following the receipt of additional tickets with similar issues an incident status notification was raised.
  • 20:50 UTC: Incident moved to "Monitoring" status.
  • 16:00 UTC 14th July: Issue marked as "Resolved" following continued monitoring and stability.

Impact

Following a  scheduled platform release, a small number of customers experienced intermittent slow performance on the Vivantio Platform.

Initial Response

Upon receiving the first support ticket, our team began investigating the issue behind the scenes and directly with the customer. As more reports emerged, the issue was escalated internally and an incident notification was published.

Root Cause & Resolution

Vivantio engineers identified elevated load on the underlying database and web infrastructure and applied additional capacity to restore normal performance, which was confirmed by 20:50 UTC. We have since closely monitored the platform with no recurrence, and our team continues a thorough review to ensure the platform's continued stability. 

We apologise for any inconvenience this caused and thank you for your patience.

Posted Jul 16, 2026 - 11:20 UTC

Resolved

Thank you for your patience whilst we have continued to monitor the performance issues from 13th July 2026.

We have not identified any new instances of the issue occuring, so we will mark this incident as resolved however our engineers will be continuing with their monitoring in the background. If you have any queries about the ongoing investigations or have a new technical issue please reach out to the Support team on support@vivantio.com.

We apologise for any inconvenience the issue may have caused.
Posted Jul 14, 2026 - 16:01 UTC

Monitoring

We are closely monitoring but all systems are now fully operational. Further details will be posted following a full investigation.
Posted Jul 13, 2026 - 20:49 UTC

Investigating

We are aware that some customers are experiencing performance issues with the Vivantio Platform.

Please be assured that our engineers are aware of the issue and are investigating this as a priority. This page will be updated within 45 minutes, or sooner if we have a further update before then.

We apologise for any inconvenience this may be causing.
Posted Jul 13, 2026 - 19:50 UTC
This incident affected: Vivantio Platform (Main Vivantio Application).